Bug report #13035

Shape Vertices Deleted by QGIS are Still Visable by Other Shapefile Viewers, including SAGAGIS

Added by Marc Hurst about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:21110

Description

I used the QGIS2.8.1 node editing tool to delete several vertices of a shapefile (to remove a small peninsula), then saved the shapefile as "pit-2-25ft-pl-setback" (attached for reference).
When I load the shapefile into QGIS, the vertices appear to have been successfully deleted (see gqis281.pdf, attached).
However, when I load the same shapefile into other shapefile viewing software, like SAGA2.1.4, the vertices do not appear to have been deleted (see saga214.pdf, attached).
Apparently the vertices were not deleted. Somehow they were made invisible to QGIS, but not to other shapefile viewers.
Is this expected behavior?
Thanks,
--Marc

pit-2-25ft-pl-setback.dbf - shapefile (98 Bytes) Marc Hurst, 2015-06-23 11:06 AM

pit-2-25ft-pl-setback.prj - shapefile (459 Bytes) Marc Hurst, 2015-06-23 11:06 AM

pit-2-25ft-pl-setback.qpj - shapefile (683 Bytes) Marc Hurst, 2015-06-23 11:06 AM

pit-2-25ft-pl-setback.shp - shapefile (3.79 KB) Marc Hurst, 2015-06-23 11:06 AM

pit-2-25ft-pl-setback.shx - shapefile (124 Bytes) Marc Hurst, 2015-06-23 11:06 AM

qgis281.pdf - image of how shapefile appears in QGIS (2.68 KB) Marc Hurst, 2015-06-23 11:06 AM

saga214.pdf - image of how shapefile appears in other shapefile viewers, like SAGA (45.6 KB) Marc Hurst, 2015-06-23 11:06 AM


Related issues

Duplicates QGIS Application - Bug report #11296: Deleting shapes in shapefiles does not work Closed 2014-09-30

History

#1 Updated by Jürgen Fischer about 5 years ago

  • Crashes QGIS or corrupts data set to No
  • Affected QGIS version set to 2.8.2
  • Status changed from Open to Closed
  • Project changed from QGIS Redmine (QGIS bug tracker) to QGIS Application
  • Tracker changed from Support to Bug report

duplicate of #11296

#2 Updated by Jürgen Fischer about 5 years ago

  • Resolution set to duplicate

Also available in: Atom PDF