Bug report #13034

Cannot render script as parent algorithm in Graphical Modeler

Added by Dalen Brauner over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/GUI
Affected QGIS version:2.8.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:21109

Description

When working in the Processing modeler, if I set the parent algorithm of anything to a script, I get a QT error. Closing the error dialogue brings me back to the processing modeler, which then immediately reopens the error dialogue. Because this continues infinitely, I'm forced to kill the process and start over.

I'm convinced the error is related to the lines drawn between objects in the modeler. Whether by some bug or otherwise, sometimes when I'm working with the modeler, the lines between objects that illustrate parent relationships disappear. I've since noticed that without these lines, I can add scripts as parent algorithms without any problems at all. But the moment the lines come back, as is the case when I re-open the modeler or fiddle with the zoom, the error instantly appears.

Text_Dump.txt Magnifier - Complete Error Text (2.79 KB) Dalen Brauner, 2015-06-23 10:34 AM

Associated revisions

Revision 2a260edb
Added by Radoslaw Guzinski about 5 years ago

[processing] [fixes #13034] Fix exception when editing model

History

#1 Updated by Saber Razmjooei over 5 years ago

  • Category changed from GUI to Processing/GUI

#2 Updated by Radoslaw Guzinski about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF