Bug report #13025

trying to compil an application using qgis 1.8 with the 2.8

Added by florent florent about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.8.2 Regression?:No
Operating System:ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21101

Description

hello
i have an old project that use the 1.8 library of qgis under ubuntu
we need to upgrade the system and the application so we decide to install the last version of ubutnu, the last version 2.8 of qgis, qt 4.8.5
but when we try to compil there is a lot of difference betwwen these two version
i don't find any documentation on how to compil a old application with old version of the qgis library with the 2.8 version
by exemple we have a lot of message like this :
qgsuniquevaluerender no such file or directory
we try to check the list of classes on qgis.org but without success

please can you help me on how to proceed

thanks a lot

History

#1 Updated by Saber Razmjooei about 5 years ago

  • Status changed from Open to Closed

Hello Florent,

This is not a bug with QGIS. With any software update you expect some changes (see for example: https://issues.qgis.org/wiki/17/Python_plugin_API_changes_from_18_to_20)

For guidance on how to upgrade your QGIS/application, best to send an email to dev/user list to help you.

I close the ticket for now. For specific problems, feel free to open new tickets.

#2 Updated by florent florent about 5 years ago

here is some more information
same problem on the header file :
qgsrenderer.h, qgssymbologyutils.h, and qgssinglesymbolrenderer.h

for the last one i replace it with qgssinglesymbolrendererv2.h and it pass but stop on other header

#3 Updated by Saber Razmjooei about 5 years ago

Problem with Build/Install is related to:
https://github.com/qgis/QGIS
and the instruction provided here:
https://github.com/qgis/QGIS/blob/master/INSTALL

For plugins and 3rd party application, not the right place to file a bug here.
As per my previous suggestion, try the mailing lists.

Also available in: Atom PDF