Bug report #13004

GRASS module r.drain won't start in Processing

Added by Marie Silvestre about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:21081

Description

I'm running QGIS dev version (dbfbc69) with GRASS 7.0.1 RC1 and Processing 2.9.3.
I'm trying to run the r.drain module from Processing with coordinates and when I try to run it, it won't start and says: "Missing parameter value: Vector layer(s) containing starting point(s)".
If I choose a vector layer instead of coordinates, nothing happens (it's reported already here: #13003)

With GRASS 6.4.4, r.drain is not working but r.drain.coordinate is.
(and r.drain.coordinate does not appear with GRASS 7)


Related issues

Related to QGIS Application - Bug report #13003: processing: add a special case for r.drain Closed 2015-06-19

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

This has been fixed here

https://github.com/qgis/QGIS/pull/2151

anyway you won't be able to use vector point layers as input, because of #13003

#2 Updated by Giovanni Manghi about 5 years ago

if you choose a vector right now it does not work because the module expectes a GRASS vector input, and Processing is passing to it a OGR one (shape or whatever you may have loaded in QGIS).

Also available in: Atom PDF