Bug report #12994

2.2 Gb osm.pbf file is not open correctly in QGIS

Added by baditaflorin - over 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.8.2 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:21072

Description

i tried to open a 2.2 GB in QGIS, and not all the ways are loading, making me think that the file is corrupt.

After spending 8 hours debugging, i figure it out that the problem is from QGIS, not my dataset

i tried with a 80 mb osm.pbf file , and all the ways are open in qgis.

the osm.pbf file that i loaded is a list of all te ways in germany

pasted_image_at_2015_06_18_05_26_pm.png (201 KB) baditaflorin -, 2015-06-18 07:54 AM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback
  • Category set to Vectors

once converting the pbf to other formats, all the features are loaded?

#2 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF