Bug report #12993

slow WFS response using big project files

Added by Henrik Uggla about 5 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:QGIS Server
Affected QGIS version:2.8.2 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:21071

Description

Serving WFS gets slow when the project file contains a large number of layers (tested with Postgis layers). The issue is present in Qgis Server 2.8.1 and 2.8.2, but not in 2.4 (2.6 not tested). WMS is not affected. Workaround: move some layers to other project files.

History

#1 Updated by Jürgen Fischer almost 5 years ago

  • Subject changed from slow Qgis Server WFS from big project files to slow WFS response using big project files

#2 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Feedback

Is this still the case in recent qgis releases?
If yes this would configure as a regression.

#3 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback.

Also available in: Atom PDF