Bug report #12974

"Select by location" does not give any warning whe using layers with different CRS

Added by Olivier Dalang almost 5 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System: Easy fix?:
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:21052

Description

Hi !

The "Select by location" tool does not work with layers with different CRS.
Currently, there's no warning message, the selection simply doesn't work (I didn't test, but it probably does the computation as if the CRS was the same for the two layers).

Since QGIS allows on the fly reprojection, I think this limitation should not exist.

Best,

Olivier

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Status changed from Open to Feedback
  • Subject changed from "Select by location" does not work with different CRS to "Select by location" does give any warning whe using layers with different CRS

This is a long standing request, see #4564

Until implemented I think that the actual bug here is that no warning is issued (other tools do).

#2 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to wontfix
  • Status changed from Feedback to Closed
  • Subject changed from "Select by location" does give any warning whe using layers with different CRS to "Select by location" does not give any warning whe using layers with different CRS

We are on the path of getting rid of the "vector" menu tools and access them only through the Processing toolobox, where the user is warned when inputs have different CRSs.

#3 Updated by Giovanni Manghi almost 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF