Bug report #12957

Feature count doesn't show correct values for PostGIS layers after deletinge features

Added by Paul Kanelli over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Legend
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21036

Description

When creating a PostGIS table (point geometry) in the "DB Manager" and adding three geometries with the QGIS "Add Feature" tool "Count Feature" is working properly. But after deleting all geometries and saving the edit "Count Feature" says there are six geometries.

feature_count_issue.jpg (104 KB) Paul Kanelli, 2015-06-13 01:53 PM

Associated revisions

Revision 37ed8390
Added by Jürgen Fischer over 5 years ago

postgres provider: fix feature count on delete (fixes #12957)

Revision 361857b0
Added by Jürgen Fischer about 5 years ago

postgres provider: fix feature count on delete (fixes #12957)

(cherry picked from commit 37ed83905f3b81ecd778c5abb1703805ce34666b)

History

#1 Updated by Giovanni Manghi over 5 years ago

  • OS version deleted (15.04)
  • Operating System deleted (Ubuntu )
  • Subject changed from Feature count doesn't show correct values for PostGIS layers to Feature count doesn't show correct values for PostGIS layers after deletinge features

Confirmed on postgis (not on shapefiles): after clicking "save" the number of features deleted is added to the feature count and not removed.

#2 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF