Bug report #12953

Canvas does not automatically refresh after saving layer edits

Added by Paul Kanelli over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:21033

Description

After saving a layer edit in QGIS 2.8.2 (Win7) I've to press F5 or change the map section to refresh the canvas. This is quite annoying when working with dynamic PostGIS views. Using QGIS 2.8.2 on Ubuntu 15.04 everythin is working fine.

canvas_refresh_issue.jpg (69.7 KB) Paul Kanelli, 2015-06-13 12:09 PM

History

#1 Updated by Jürgen Fischer over 5 years ago

Because what you changed also has an indirect effect on other layers on the postgres side?

#2 Updated by Jürgen Fischer over 5 years ago

  • Status changed from Open to Feedback

#3 Updated by Giovanni Manghi over 5 years ago

  • Category set to Map Canvas
  • Operating System set to Windows

#4 Updated by Paul Kanelli over 5 years ago

Jürgen Fischer wrote:

Because what you changed also has an indirect effect on other layers on the postgres side?

Dynamic buffers for example do not refresh automatically when saving new geometries to buffer.

#5 Updated by Jürgen Fischer over 5 years ago

  • Category deleted (Map Canvas)

Paul Kanelli wrote:

Jürgen Fischer wrote:

Because what you changed also has an indirect effect on other layers on the postgres side?

Dynamic buffers for example do not refresh automatically when saving new geometries to buffer.

What do you mean with dynamic buffers? Is the layer that you change not refreshed or is it another layer that is not refreshed?

#6 Updated by Paul Kanelli over 5 years ago

When deleting or creating new geometries to buffer the PostGIS view/layer with the dynamic buffers isn't affected by the changes before refreshing the canvas by pressing F5 or changing the map section using the "Pan Map" or "Zoom" tool. This only happens using Windows. On Ubuntu the whole canvas refreshes automatically when saving a layer edit.

#7 Updated by Jürgen Fischer over 5 years ago

Paul Kanelli wrote:

When deleting or creating new geometries to buffer the PostGIS view/layer with the dynamic buffers isn't affected by the changes before refreshing the canvas by pressing F5 or changing the map section using the "Pan Map" or "Zoom" tool. This only happens using Windows. On Ubuntu the whole canvas refreshes automatically when saving a layer edit.

Sorry, that still doesn't clearly answer my question. Please provide an example.

#8 Updated by Paul Kanelli over 5 years ago

Just noticed the same issue appears using QGIS 2.9.0-Master on Ubuntu 15.04. Pleaese see the attached image. I've deleted two of three "points_to_buffer" geometries and saved the layer edits. "Show Feature Counts" says there is one "buffer_50m" geometry but three "buffer_50m" geometries are still displayed.

"buffer_50m" is a PostGIS view:

CREATE VIEW buffer_50m AS
SELECT
gid,
ST_Buffer(geom, 50)::geometry(polygon, SRID)
FROM point_to_puffer;

BTW: The feature count of the "point_to_buffer" layer includes the deleted geometries too. There is only one "point_to_buffer" geometry in my PostGIS table.

#9 Updated by Jürgen Fischer over 5 years ago

  • Resolution set to wontfix
  • Status changed from Feedback to Closed
  • Operating System deleted (Windows)

QGIS doesn't know that the layers are related. Redrawing all layers if one changes is usually not necessary, but might be expensive - that's why their output is cached. So changing that would probably raise other issues.

Also available in: Atom PDF