Bug report #12940

Advanced digitizing doesn't work when coordinates are given

Added by Jérôme Guélat about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:21020

Description

It is currently impossible (QGIS 2.8.2) to use the new advanced digitizing tool to digitize a normal square. I'm using the following workflow:

1. Create a new layer (shapefile or virtual layer)
2. Activate advanced digitizing
3. Create the first vertex: press x, write 0, lock with Enter, then press y, write 0, lock with Enter, click to create the vertex
4. Create the second vertex: press x, write 1, lock with Enter, then press y, write 0, lock with Enter, click to create the vertex
5. Try to create the third vertex: press x, write 1, lock with Enter, then press y, write 1, lock with Enter, click to create the vertex

The third vertex is always wrongly created at coordinates (1,0) instead of (1,1), which creates a geometry error since 2 vertices are identical.

Associated revisions

Revision 646b445b
Added by Martin Dobias about 5 years ago

Fix locking logic with X,Y locked and soft locks to angle (fixes #12940)

Revision be0dae19
Added by Martin Dobias almost 5 years ago

Fix locking logic with X,Y locked and soft locks to angle (fixes #12940)

(cherry picked from commit 646b445bf799daf4bc2a09b88bc6b6f2dc51d545)

History

#1 Updated by Martin Dobias about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF