Bug report #12837

QGIS Crashing When Connecting to datasets in MSSQL

Added by Richard G over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider/MSSQL
Affected QGIS version:2.8.2 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:20932

Description

Using QGIS I have connected to a database from MSSQL with no issues.

When I import one feature I can specify the coordinate system and edit attributes. However, if I wish to add a second feature and do the same I constantly get the following error message: "*Crash dumped - minidump written to C:*"

In Add MSSQL Table(s) I have the following information:

[Schema: sde] [Geometry column: Shape/SHAPE] [SRID: 5 digit code] [Primary key column: (Blank)] [Select at id: (Checked)] [sql: (Blank)]

Does anybody know what may be causing QGIS to crash?


Related issues

Duplicates QGIS Application - Feature request #10946: Non-integer key columns in MSSQL Open 2014-07-24

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Category set to Data Provider/MSSQL
  • Status changed from Open to Feedback
  • Target version set to Future Release - High Priority

Did it worked fine with previous qgis releases?

#2 Updated by Richard G over 4 years ago

  • Assignee set to Giovanni Manghi

Hello thanks. It did not work for me in 2.6. It does however work for me in 2.2.0 Valmiera. Any thoughts as to why it is not working for me in the latest versions of the software?

#3 Updated by Giovanni Manghi over 4 years ago

  • Assignee deleted (Giovanni Manghi)

Richard G wrote:

Hello thanks. It did not work for me in 2.6. It does however work for me in 2.2.0 Valmiera. Any thoughts as to why it is not working for me in the latest versions of the software?

yes, is called bug :)
Sorry I can't do tests of my own, I don't have/do MS SQL Server.

#4 Updated by Saber Razmjooei over 4 years ago

Did you check this #12324?

#5 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Saber Razmjooei wrote:

Did you check this #12324?

that should be duplicate of #10946
Please reopen if necessary.

Also available in: Atom PDF