Bug report #12836

serious regression: rendering process of layers fail to render on canvas and composer map items

Added by Mathieu Pellerin - nIRV over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Marco Hugentobler
Category:Map Canvas
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20931

Description

Since at most 4 days, QGIS fails to render layers onto the canvas (and composer map items), but will show in the overview panel. Chances are this is a regression from the new geometry classes commits

Steps to reproduce:
  1. Decompress the attached zip file
  2. Launch QGIS and make sure the overview panel is open
  3. Load the hmm.qgs project file
  4. After a couple of seconds, you'll notice the two project layers show up on the overview panel, but nothing on the main canvas
  5. Drag the canvas, zoom in and out, and take note of the absence of anything being drawn
  6. If you open a composer, you'll notice the map items starting to draw the first layer (Provinces_region) and stopping in the process, leaving a half-drawn first layer, while the second layer is entirely missing

hmm.zip (1.47 MB) Mathieu Pellerin - nIRV, 2015-05-27 09:34 PM

Associated revisions

Revision 08f2f413
Added by Marco Hugentobler over 4 years ago

Make geometry import/export more robust in case of invalid geometries. Fixes #12836

History

#1 Updated by Mathieu Pellerin - nIRV over 4 years ago

#2 Updated by Giovanni Manghi over 4 years ago

  • Target version set to Future Release - High Priority
  • Category set to Map Canvas

#3 Updated by Giovanni Manghi over 4 years ago

with this project I also get "unknown exception" warnings when opening/creating/zooming print layouts. I don't see such issues in other projects.

#4 Updated by Marco Hugentobler over 4 years ago

  • Assignee set to Marco Hugentobler

#5 Updated by Marco Hugentobler over 4 years ago

Ok, I can reproduce this one. It seems to be a combination of geometry simplification and labeling which causes the issue.

#6 Updated by Tomasz Nycz over 4 years ago

I have geometry simplification turned off. In project with PostGIS layers, on main map canvas everything is OK, but in composer if I try to move, or change extent of composer map, "unknown exceptions" throws out. On map the map there is only one layer drawn, no labels at all. If I move composer map extent from area where is no data, warning is showing when I go into layer extent, and draws only this piece. Further moving map doesn't change anything.

#7 Updated by Marco Hugentobler over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF