Bug report #12804

The Label Option: FirstCap return always " all uppercase"

Added by aperi2007 - over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Labelling
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20900

Description

As in subject:

the label option "FirstCap" return a label always ALL-Uppercase.
Instead it should return Upper the first letter and lower all the others.

I see this issue on qgis 2.8.2 32bit (windows)


Related issues

Duplicates QGIS Application - Feature request #7611: Title case option which also operates on uppercase words Reopened 2013-04-14

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #7611

#2 Updated by aperi2007 - over 5 years ago

  • Status changed from Closed to Reopened

No, it is not a duplicate of other ticket.

In the ther ticket it was proposed a workaround at program level .

This is not possible to apply to the interface level.

Also the question is that is wrong the functionality.

Infact the FirstCap, dont mean put the first Upper and leave the other unchanged.
But instead mean Put only the first up and all the other should be lower.

#3 Updated by aperi2007 - over 5 years ago

  • Resolution deleted (duplicate)

#4 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Reopened to Feedback

Infact the FirstCap, dont mean put the first Upper and leave the other unchanged.
But instead mean Put only the first up and all the other should be lower.

that is exactly what #7611 is about. Please leave feedback.

#5 Updated by Saber Razmjooei over 5 years ago

  • Status changed from Feedback to Closed

It is duplicate of #7611 and closed.
Please provide some screenshots and more info if you intend to reopen the ticket.

Also available in: Atom PDF