Bug report #12779

Attribute table edits appear not to be working after sort

Added by Joeri Theelen over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:2.6.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20878

Description

I guess this is a bug:
  1. start QGIS and load a shapefile;
  2. open the shapefile attribute table and start an edit session;
  3. now SORT the attribute table on one of its columns: in my situation, I sorted a field to group all NULL values at the top of the table for ease of editing;
  4. edit one of the attributes in the table: in my case, I tried to give an attribute a value where it was NULL.

You'll notice that the attribute does NOT update, like if the value is not accepted. But the value is updated correctly, e.g. sort again on any field and look for the updated value: this action will trigger the update visually. The problem is that QGIS does not show the updated value right away. Probably because of the sorting. If you do not sort (step 3), there is no issue.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Hi, this has been fixed in latest qgis versions, give a try to 2.8.2. Cheers!

Also available in: Atom PDF