Bug report #12777

Processing: Grass 7 r.relief has different "units" parameter than Grass 6 version r.shaded.relief

Added by Markus Mayr over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Processing/GRASS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20876

Description

The algorithm r.relief can not be executed since the parameters for "units" have changed from "none, meters, feet" to "intl, survey". The algorithm no longer accepts "none" as a valid input and stops working.

Unless this parameter can be made optional, it should be removed. Can it even be made optional?

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Category set to Processing/GRASS
  • Affected QGIS version changed from 2.8.2 to master

#2 Updated by Giovanni Manghi over 4 years ago

  • Pull Request or Patch supplied changed from No to Yes

#3 Updated by Giovanni Manghi over 4 years ago

  • Assignee set to Giovanni Manghi

#4 Updated by Markus Mayr over 4 years ago

(I mistakenly commented on GitHub - I moved the comment here)

As I understood the description ("With an elevation map measured in feet, the units option can be set to automatically convert meters to international feet (0.3048 meters = 1 foot) or survey feet (1200 / 3937 meters = 1 foot)."), it is now impossible to use a height map containing values in meter since one of the two parameters ("intl" or "survey") is always used?

Speaking from a cartographic point of view, the resulting picture looks fine, but from a geodetic view, the result is wrong.
(I'm referring to the "fix" in post #1).

#5 Updated by Giovanni Manghi over 4 years ago

Markus Mayr wrote:

(I mistakenly commented on GitHub - I moved the comment here)

As I understood the description ("With an elevation map measured in feet, the units option can be set to automatically convert meters to international feet (0.3048 meters = 1 foot) or survey feet (1200 / 3937 meters = 1 foot)."), it is now impossible to use a height map containing values in meter since one of the two parameters ("intl" or "survey") is always used?

Speaking from a cartographic point of view, the resulting picture looks fine, but from a geodetic view, the result is wrong.
(I'm referring to the "fix" in post #1).

better fix here

https://github.com/qgis/QGIS/pull/2072

the module needs to be split as Processing does not support optional parameters at the moment.

#6 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF