Bug report #12770

shapefile gets corrupted after editing

Added by Weronika Rapa over 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20869

Description

I'm using Windows 8.1, tried few versions of QGIS and they all give me the same problem. Have no issues editing the shapefiles but then something goes wrong when saving a shapefile and the project. The dbf gets corrupted, changes it's name to name_packed. It destroys the edits, changing name back does not fix it, there are features missing and the attributes get completely messed up.

Boundary.zip (113 KB) Weronika Rapa, 2015-06-17 07:02 AM

mixed_columns.png - table after the corruption (11.2 KB) Mohamed Houd, 2015-08-25 02:19 AM

Original_table.png - table before the corruption (12.8 KB) Mohamed Houd, 2015-08-25 02:19 AM

History

#1 Updated by Saber Razmjooei over 4 years ago

Maybe worth providing sample data.

#2 Updated by Saber Razmjooei over 4 years ago

  • Status changed from Open to Feedback

#3 Updated by Giovanni Manghi over 4 years ago

  • Subject changed from dbf packed to shapefile gets corrupted after editing
  • Category set to Digitising

are you doing concurrent editions of this shapes? are you manually editing the shapefile with a program like libre/ms office?

Please use meaningful subjects. Cheers!

#4 Updated by Weronika Rapa over 4 years ago

No, I'm not doing any concurrent edits. It happens while saving the shapefile or sometimes when saving the project itself (when the shapefile is not even in edit mode).

#5 Updated by Giovanni Manghi over 4 years ago

Weronika Rapa wrote:

No, I'm not doing any concurrent edits. It happens while saving the shapefile or sometimes when saving the project itself (when the shapefile is not even in edit mode).

does it happens with any shapefile? or just a particular one? please attach sample project/data anyway.

#6 Updated by Weronika Rapa over 4 years ago

Happened on many occasions with different shps and projects. Had no issues before I started working on new computer with Windows 8.1.
Regarding attached data, I was working on the shapefile 'species', then the dbf got 'packed' so I lost all the attributes. Had to do typed them again as on the shp 'species_re_done'. Sometimes apart from loosing attributes some features also disappear.

#7 Updated by Giovanni Manghi over 4 years ago

Weronika Rapa wrote:

Happened on many occasions with different shps and projects. Had no issues before I started working on new computer with Windows 8.1.
Regarding attached data, I was working on the shapefile 'species', then the dbf got 'packed' so I lost all the attributes. Had to do typed them again as on the shp 'species_re_done'. Sometimes apart from loosing attributes some features also disappear.

does it happen on other computers? have you tried on a clean installation of qgis (no 3rd party plugins installed)?

#8 Updated by Weronika Rapa over 4 years ago

Doesn't happen on other computer with Vista, I'll try on a clean installation though, thanks for suggestion!

#9 Updated by Mohamed Houd about 4 years ago

I get the same problems when editing a shapefile that was created first under QGIS 2.6 and opened after with QGIS 2.8.1 same on mac with QGIS 2.8.2. The corruption happened when i added one column "indice ::text". The file is now corrupted and attribute table columns are now mixed up.

Please see the images linked here for more details.

#10 Updated by Giovanni Manghi almost 4 years ago

Mohamed Houd wrote:

I get the same problems when editing a shapefile that was created first under QGIS 2.6 and opened after with QGIS 2.8.1 same on mac with QGIS 2.8.2. The corruption happened when i added one column "indice ::text". The file is now corrupted and attribute table columns are now mixed up.

Please see the images linked here for more details.

see #13298

#11 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to duplicate

I think that the original report/description is duplicate of #11007, that will be fixed (hopefully) in time for the next release.

Also available in: Atom PDF