Bug report #1277

digitizing with snapping option works verry slow

Added by Gerhard Spieles about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:11337

Description

when "snapping options" in the menue "project properties" ist enabled to a large shp-layer (17.000 objects) the digitize function (edit shp file) work verry slow.

raeumlicher_index.pdf (205 KB) Gerhard Spieles, 2008-09-04 01:02 PM

spartial_idex_fail.jpg - spartial index fails with sample data (198 KB) Gerhard Spieles, 2008-09-05 06:03 AM

History

#1 Updated by Maciej Sieczka - about 12 years ago

A way to speed digitizing up was to use "Cross" instead of "Semi transparent circle" for the "Marker style" in Preferences, in my case. See if that helps and please report back.

#2 Updated by Gerhard Spieles about 12 years ago

Speed is little better, but not good for work

#3 Updated by Marco Hugentobler about 12 years ago

The most effective way to speed up the snapping is to have a spatial index. Otherwise, every vertex of the whole dataset needs to be tested.

Do you already have an index on the dataset? If not, you may create one in the vector layer properties dialog:

Open vector layer properties dialog, go to tab 'general', press button named 'create spatial index'.

Marco

#4 Updated by Gerhard Spieles about 12 years ago

Thanks for advice, but creating spatial index failes (see attached pdf-file

#5 Updated by Maciej Sieczka - about 12 years ago

Replying to [comment:5 gespiel]:

Thanks for advice, but creating spatial index failes

Works for me, with my data. If you can still reproduce it please open a separate ticket and attach sample data to reproduce the problem.

(see attached pdf-file

FWIW, you can attach JPEGs or PNGs as well.

#6 Updated by Gerhard Spieles about 12 years ago

sample data produce the same problem
(see attached jpg)

#7 Updated by Maciej Sieczka - about 12 years ago

Replying to [comment:7 gespiel]:

sample data produce the same problem
(see attached jpg)

I asked you to open a separate ticket for the issue regarding spatial index. It's bad to discuss 2 separate issues in the same ticket.

And please upload some sample data into that new ticket (e.g. a Shapefile) to reproduce the problem with - a screendump is not enough!

#8 Updated by Gerhard Spieles about 12 years ago

Sorry, [email protected] open a new ticket soon.

#9 Updated by Marco Hugentobler about 12 years ago

  • Status changed from Open to Closed
  • Resolution set to wontfix

I'm closing this ticket as the problem is covered by the new ticket. Without a spatial index, it is not possible to have good snapping performance for large data files.

Marco

#10 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF