Bug report #12760

Qgis 2.8, gdal python scripts gives error at end of process

Added by Henry White almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GDAL Tools
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:Yes Copied to github as #:20859

Description

I am using Qgis 2.8.1 64-bit (Standalone installer) on Windows 7 64-bit. In the OSGeo4W Shell I am encountering a problem with some gdal/ogr python scripts where python.exe crashes upon script termination.
The problem seems to be restricted to gdal2tiles and gdal_calc, I have done some quick testing and the problem doesn't seem to exist for other scripts.

This issue has been brought up earlier on gis.stackexchange.com http://gis.stackexchange.com/questions/101921/gdal-calc-works-but-i-get-a-python-error-at-the-end-of-each-process-that-prevent

System information: Path in OSGeo4W Shell:
C:\\PROGRA~1\\QGISWI~1\\apps\\Python27\\Scripts;C:\\PROGRA~1\\QGISWI~1\\bin;C:\\Windows\\system32;C:\\Windows;C:\\Windows\\WBem; C:\\PROGRA~1\\QGISWI~1\\apps\\msys\\bin

pythonhome:
C:\\PROGRA~1\\QGISWI~1\\apps\\Python27

gdal_data:
C:\\PROGRA~1\\QGISWI~1\\share\\gdal

aOlah.png (40.8 KB) Henry White, 2015-05-17 11:25 PM

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

there are indeed issues with gdal lately (I have seen then also on linux), but this is not caused by qgis.

Also available in: Atom PDF