Bug report #12748

crash creating layer from delimited text file

Added by zamir rasid about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Data Provider/Delimited Text
Affected QGIS version:2.8.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:20847

Description

hello. my name is zamir and i'am a new user for qgis. i want to report a bug that i encountered.
Right now im doing the tutorial for points in polygon analysis by Ujaval Gandhi.

1. i want to create a new layer from a delimited text file, file name signif.txt
2. the encoding is system
3. the layer settings is (checked) use spatial index.
4. when i click OK, this crashed qgis.
5. but when i unchecked the use spatial index, it does not crash qgis.
6. btw, im using windows 7 ultimate 64bit and using qgis 2.8.2 64 bit. im guessing this is problem with my windows because my other classmates did not have any problem. i also tried version 2.8.1 64bit on similar laptop and crash also happened.
7. there are lots of other crashes that i encountered but i figured that this problem is the starting point.

im on training for qgis so if you could please assist me on this it would be a great help. thanks a bunch!

best regards,
zamir

error.png (81.6 KB) zamir rasid, 2015-05-13 10:44 PM

signif.txt Magnifier (780 KB) zamir rasid, 2015-05-14 07:28 AM

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Subject changed from create layer from delimited text file to crash creating layer from delimited text file
  • Crashes QGIS or corrupts data changed from No to Yes
  • Target version set to Version 2.10
  • Status changed from Open to Feedback
  • Category set to Data Provider/Delimited Text

Please attach the offending csv file.

#2 Updated by zamir rasid about 5 years ago

  • % Done changed from 0 to 100
  • File signif.txtMagnifier added

dear Giovanni Manghi,
thank you for your feedback. it seems that i have solved this issue by updating my windows 7.
as i mentioned earlier i have encountered other problems as well, and thank goodness all of these problem was resolved after i updated my win 7 via windows update!
again, thank you very much for assisting me.
hope that QGIS and your team will continue to prosper.
keep up the good work!

best regards,
zamir

#3 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

Also available in: Atom PDF