Bug report #12732

segfault in qtwebkit-4.8.6

Added by Victor Matare about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:2.8.1 Regression?:No
Operating System:gentoo amd64 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:20832

Description

for me, qgis 2.8.1 consistently produces the attached segfault when adding an OpenLayers basemap. Now I realize this happens somewhere deep inside the JS implementation ported from WebKit by the qtwebkit project. But I'm not sure where else to report this since the qtwebkit guys have probably moved on to QT 5. Honestly, this looks like a pretty messy bug in qtwebkit, so what are my options here? Is there any way to compile against current qt(webkit)? That is 5-ish?

qgis-qtwebkit-segfault-bt - full backtrace incl. locals (11.2 KB) Victor Matare, 2015-05-11 04:56 PM

History

#1 Updated by Victor Matare about 5 years ago

just found the QT5 cmake option, will try to build against QT5 and report back.

#2 Updated by Victor Matare about 5 years ago

  • Status changed from Open to Closed

Well, just found I had a pretty old version of the OpenLayers plugin, which apparently manages to kill qtwebkit with a pretty weird JS syntax error. After upgrading the plugin, the segfault is gone, and given that there's also the option of building against QT5, this issue appears obsolete. Sorry for the noise.

Also available in: Atom PDF