Bug report #12699

Plugin Manager : Installed plugins list is not sorted

Added by Harrissou Santanna about 5 years ago. Updated over 2 years ago.

Status:Closed
Priority:Low
Assignee:Borys Jurgiel
Category:Plugin Manager
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20805

Description

In Plugin Manager, unlike the other tabs, the Installed tab shows the list of plugins in a weird order. Should better be sorted.

UnorderedlistPlugin.png (42.8 KB) Harrissou Santanna, 2015-06-18 05:44 AM

UnorderedlistPlugin2.png (52.3 KB) Harrissou Santanna, 2015-06-18 05:44 AM

History

#1 Updated by Harrissou Santanna about 5 years ago

Weird. After I report this issue, I'm no more able to reproduce it. All goes well.
May be closed and set as invalid unless someone confirms...

#2 Updated by Giovanni Manghi about 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

#3 Updated by Harrissou Santanna about 5 years ago

I don't know if I have to reopen the issue (otherwise, what is reopening option for?) or create new issue but I reproduce the issue I reported above. I attach two screenshots that show what happens.
However it's not a big issue because once I closed the dialog and reopened it, everything was well sorted.
Happen on an osgeo4w 64bits installed on win7 machine

#4 Updated by Borys Jurgiel about 5 years ago

So does it happen incidentally, or all the time on this computer? If incidentally, are you able to recall that situation? Was it just after first opening the Manager during that QGIS session, or after some installing/deinstalling (something that could change state of some plugins)?

#5 Updated by Harrissou Santanna about 5 years ago

Not all the time, I hadn't remarked this since my previous report. The day I got it, It was :
- the first time I launch QGIS since the computer was ON
- the first time opening the plugin manager
- and I upgraded some plugins.
I can't tell what is related to this bug but I'll watch and report if I can reproduce it.

#6 Updated by Giovanni Manghi about 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#7 Updated by Borys Jurgiel over 2 years ago

Is it still valid? I was never able to reproduce it...

#8 Updated by Harrissou Santanna over 2 years ago

  • Status changed from Reopened to Closed

Me neither. Closing.

Also available in: Atom PDF