Bug report #12672

SAGA Kriging in QGIS is slower than in SAGA itself

Added by Marcel Foelsch almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:2.8.1 Regression?:No
Operating System:Win7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20779

Description

The interpolating tool (saga ordinary kriging) is very slow in QGIS. It took 30 minutes in QGIS to interpolate a shape file with 300.000 points. The same job was done in SAGA GUI within 3 minutes.

History

#1 Updated by Victor Olaya almost 5 years ago

  • Status changed from Open to Closed

When calling from QGIS there is a need for more operations, since SAGA does not generate results in formats compatible with QGIS. So this is not a bug, but a result of that, and there is nothing we can do.

You can try yourself to run all the operations that QGIS performs with SAGA, and compare that to the cost of doing it directly in SAGA, and the result will probably be very similar.

Also available in: Atom PDF