Bug report #12665

pyodbc DLL issue in 32-bit standalone

Added by Gary Sherman over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.8.1 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:20773

Description

pyodbc distributed with the 32-bit Windows standalone version fails to load. This appears to be related to the way it was built against msvrc90.dll? This issue doesn't occur on the 64-bit standalone or using the OSGeo4W Network installer:

Python Console

Use iface to access QGIS API interface or Type help(iface) for more info
 >>> import pyodbc
Traceback (most recent call last):
  File "<input>", line 1, in <module>
  File "C:/QGIS_W~1/apps/qgis/./python\\qgis\\utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
ImportError: DLL load failed: The specified module could not be found.


Related issues

Duplicates QGIS Application - Bug report #12489: QGIS 2.8.1 32-bit cannot import pyodbc Closed 2015-04-01

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to up/downstream
  • Priority changed from High to Normal
  • Status changed from Open to Closed

duplicate of #12489

Also available in: Atom PDF