Bug report #12646

Split RGB bands stopped to work in latest Processing releases

Added by Giovanni Manghi over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20759

Description

it worked fine until Processing shipped with qgis 2.6.1, since then the module does not work anymore.

History

#1 Updated by Victor Olaya over 4 years ago

  • Status changed from Open to Feedback

i should be fine now. seems that 2.1.4 changed (again) the naming of output files for that algorithm.

However, i see frequent crashes of the module in windows, even when called from the console...but the algorithm shoudl be correct now

#2 Updated by Giovanni Manghi over 4 years ago

on Linux (qgis master) I get

A iniciar o algoritmo Split RGB bands...
/home/giovanni/.qgis2//processing/saga_batch_job.sh: 5: /home/giovanni/.qgis2//processing/saga_batch_job.sh: Syntax error: Unterminated quoted string

#3 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Open

#4 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Version 2.8.2 to Version 2.10

#5 Updated by Victor Olaya over 4 years ago

Giovanni, could you upload that sh file, so i can see what is wrong with it?

Thanks!

#6 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Version 2.10 to Future Release - High Priority
  • Pull Request or Patch supplied changed from No to Yes
  • Affected QGIS version changed from 2.8.1 to master

#7 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF