Bug report #12633

Incorrect area calculation

Added by oliver Moore over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20748

Description

Using google hybrid layer, project CRS epsg 3857, enabled OTF projection, and polygon layer at same crs, project map tools set to non-planimetric.
When you use the 'i' info tool it defines the polygon layers area to approximately 3 time the real value.
If I change from none/planimetric to wgs 84 it returns and area of zero.

This worked correctly in previous versions but seems to be broken now.

Please advise this is very frustrating.


Related issues

Duplicates QGIS Application - Bug report #12057: Computed area is wrong when reprojection is active Closed 2015-01-26

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF