Bug report #12545

Wrong features count filtering a Postgresql layer

Added by stefano nardone over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.8.1 Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20687

Description

If I open the query builder for adding a filter on a Postgresql layer in QGIS and input a filter expression, the 'test' button returns a wrong count of the features obtained with filter applied (it returns the whole features number). The wrong count number is shown also if I activate the 'show features count' option for the layer in the layers panel, but the rendered features are those correctly filtered, and so are also the rows shown in the attribute table (with correct number displayed too).


Related issues

Duplicates QGIS Application - Bug report #7780: Incorrect number of rows when testing layer filter expres... Closed 2013-05-08

History

#1 Updated by Jürgen Fischer over 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #7780

Also available in: Atom PDF