Bug report #12528

Processing plugin starts with Python error

Added by Janos Meszaros over 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20672

Description

After the upgrade of Processing plugin to 2.9 version on QGIS 2.8.1, it pops up a window with Python error when QGIS starts:
IOError: [Errno 2] No such file or directory: 'nul'

The 'Null' entry in 'not Plug and Play Drivers' and values in HKEY_LOCAL_MACHINE\\SYSTEM\\CurrentControlSet?\\services\\Null were also checked and everything seemed to be configured right.

Total log file was attached as a text file.

processing_error_atstart.txt Magnifier (3.37 KB) Janos Meszaros, 2015-04-08 03:11 AM

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback
  • Priority changed from Severe/Regression to Normal

cannot confirm here on the same platform, please try removing the .qgis2 (after eventually make a copy of it) and upgrading again Processing. Thanks.

#2 Updated by Janos Meszaros over 5 years ago

Thank you for the info but unfortunately it didn't help. What I also tried before:
Total reinstall of QGIS and other OSGIS software using OSGeo4W installer advanced mode ->not helped
Reinstall Processing plugin manually using the zipped version from plugins website -> not helped
Your suggestion with .qgis2 folder -> not helped

I think this problem somehow related only to my notebook and environment because I didn't find this or similar issue searching on various OSGIS related websites...

#3 Updated by Giovanni Manghi over 5 years ago

I think this problem somehow related only to my notebook and environment because I didn't find this or similar issue searching on various OSGIS related websites...

seems a local issue to me too.

#4 Updated by Janos Meszaros over 5 years ago

Yes, I confirm that it was related to my Win 7 environment. After a total Win 7 reinstall everything works as it has. Please close this issue or delete to not confuse other people.

#5 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Feedback to Closed
  • Resolution set to invalid

#6 Updated by Giovanni Manghi about 5 years ago

  • Category changed from 94 to Processing/Core

Also available in: Atom PDF