Bug report #12484

QGIS Server: invalid list of of layers in "LayerDrawingOrder" when using embedded groups/layers

Added by Andreas Neumann over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:QGIS Server
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20632

Description

When using embedded groups/layers in a QGIS project, QGIS server does not include all individual layers in the element "LayerDrawingOrder" of the "GetProjectSettings" command. Some layers are ommitted. We need a complete list of every physical layer (not just groups) for QGIS web client in order to formulate correct WMS queries.

The image attached shows the correct layer order on the left in QGIS desktop and the invalid list in the web-browser showing the results of the "GetProjectSettings" command.

In my project I embed several groups in parallel from the same linked project.

This is a big problem for us because we use the embedded layers/groups a lot.

layer_zeichenreihenfolge_qgis_desktop_vs_server.png - Screenshot demonstrating the problem - correct layer order in QGIS desktop on the left, invalid order in QGIS server (486 KB) Andreas Neumann, 2015-04-01 02:54 AM

Associated revisions

Revision de5a3f5e
Added by Jürgen Fischer over 4 years ago

server: fix 'LayerDrawingOrder' (fixes #12484)

Revision d92e4d64
Added by Jürgen Fischer over 4 years ago

server: fix 'LayerDrawingOrder' (fixes #12484)

cherry picked from de5a3f5 + 04324fd

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF