Bug report #12478

Estimated extent of PostGIS layers with mixed case names

Added by Luca Sigfrido Percich about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20626

Description

When adding a PostGIS layer with a mixed case name, the following error is reported in the log window:

Erroneous query: SELECT st_estimatedextent('loader','AnagraficaStrade','geom') returned 7 [ERROR: relation "loader.anagraficastrade" does not exist]

Passing st_estimatedextent a double-quoted table name works: SELECT st_estimatedextent('loader','"AnagraficaStrade"','geom').

After signaling this to the postgis tracker (http://trac.osgeo.org/postgis/ticket/3093), it turns out that this behaviour isn't going to change.


Related issues

Duplicates QGIS Application - Bug report #9230: Double quote schema and table names Closed 2013-12-18

Associated revisions

Revision 048aff01
Added by Jürgen Fischer almost 5 years ago

use triple quoting with st_estimatedextent in postgres provider and db_manager (fixes #12478)

Revision 8300521e
Added by Jürgen Fischer over 4 years ago

Revert "use triple quoting with st_estimatedextent in postgres provider and db_manager (fixes #12478)"

As it seems to address a meanwhile reverted behavior change in PostGIS 2.1
before it was released (see also https://trac.osgeo.org/postgis/ticket/2834).

This reverts commit 048aff01bb9cf42e2c1c17eb0ddbd81537443e19.

(cherry picked from commit e4410abb93e74ca6e85e11f5916e8c07c417e06f)

Revision 48e4fb85
Added by Jürgen Fischer over 4 years ago

Revert "use triple quoting with st_estimatedextent in postgres provider and db_manager (fixes #12478)"

As it seems to address a meanwhile reverted behavior change in PostGIS 2.1
before it was released (see also https://trac.osgeo.org/postgis/ticket/2834).

This reverts commit 048aff01bb9cf42e2c1c17eb0ddbd81537443e19.

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Category set to Data Provider/PostGIS

#2 Updated by Jürgen Fischer almost 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF