Bug report #12473

$area malfunctioning

Added by mara Gittleman over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20621

Description

Calculating area using field calculator results in faulty numbers. Calculating area using Vector --> Geometry Tools --> Export/Add Geometry Columns works.

I'm on a mac, using 2.8.1.

Attached is an example. gardenArea was calculated using field calculator, area was calculated using Export/Add Geometry Columns. Also not sure why it's an integer and not float.

test-garden.zip (3.01 KB) mara Gittleman, 2015-03-29 08:07 PM

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback
  • Category set to Vectors

likely duplicate of #10966

can you confirm?

#2 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Also available in: Atom PDF