Bug report #12447

Regression in Postgres provider (master)

Added by Roel Huybrechts about 5 years ago. Updated about 5 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20613

Description

A recent 250eb74 (using git bisect) to master introduces a regression in the postgres provider. When adding a new feature, the schema is no longer present in the nextval function to get the new value for the primary key.

Steps to reproduce:
  • Add a PostGIS layer (preferably from schema != 'public').
  • Enable edit mode.
  • Add a feature.
Result:
  • The default value for the primary key reads f.ex. nextval('testlayer_gid_seq'::regclass) where it used to read f.ex. nextval('data.testlayer_gid_seq'::regclass)
  • As a consequence, saving the layer with the new feature fails since the sequence cannot be found.

Associated revisions

Revision 581d7f8e
Added by Jürgen Fischer about 5 years ago

postgres provider: fix retrieval of default values from other schemes (fixes #12447)

History

#1 Updated by Jürgen Fischer about 5 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF