Bug report #12378

Label placement for polygons

Added by Zoltan Szecsei over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Normal
Assignee:Giovanni Manghi
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20552

Description

Hi,
Implementing Feature Request #12136 should fix this, but at the moment it needs to be a bug.
When zooming in and out, the labels get repositioned so that polygons that are only partially in your viewport, are still labelled. This causes the label to sometimes be placed inside the wrong polygon - which is not great when you print maps (on screen you can at least talk your way through the glitch :-) )

42.jpg - Label 57202075 should be above the line (and is, if I zoom out a bit) (21 KB) Zoltan Szecsei, 2015-03-16 09:28 AM

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Status changed from Open to Feedback
  • Category set to Labelling

"When zooming in and out, the labels get repositioned so that polygons that are only partially in your viewport, are still labelled."

this is just an option that you can disable. And there is also an option "force point inside polygon".

#2 Updated by Zoltan Szecsei over 5 years ago

  • Assignee set to Giovanni Manghi
  • Status changed from Feedback to Closed

Hi Giovanni,
The Centroid set to "Whole Polygon" removes the problem, but leaves the polygon (piece) unlabelled.
The "Force Point Inside Polygon" seems to have no effect.
But moving "Placement" to "Horizontal (slow) does the trick.

In short - there are plenty of ways to fiddle around until I get what I need.

Thanks,
Zoltan

#3 Updated by Giovanni Manghi over 5 years ago

The "Force Point Inside Polygon" seems to have no effect.~

weird, it works fine here.

#4 Updated by Zoltan Szecsei over 5 years ago

It might just be because of the particular zoom scale I was at.
I can see why no setting will work for every case, so I'm happy to fiddle until a "correct" placement "appears", as there are plenty toggles to play with.
Thanks for being so quick with suggestions.

Cheers for now,
Zoltan

Also available in: Atom PDF