Bug report #12375

Dissolve plugin not working properly

Added by Ger CO over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:2.8.1 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:20549

Description

when indicating a field to dissolve, that field is not properly used. still duplicates occur!
furthermore, i desperately miss the option of indicating fields that are maintained after dissolve opeations. i´dlike to have the options sum, min, mean, max, range, etc.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Subject changed from Dissolve plugin not working properly and lacks the option of field statistics to Dissolve plugin not working properly
  • Status changed from Open to Feedback

it is already fixed in QGIS master with a new tool in the Processing toolbox (GDAL/OGR > Geoprocessing).

Anyway: what dissolve tool is not working for you? beside the one in the "vector" menu there are at least 3 alternatives in the Processing toolbox (QGIS, GRASS and SAGA).

#2 Updated by Giovanni Manghi over 4 years ago

Giovanni Manghi wrote:

it is already fixed in QGIS master with a new tool in the Processing toolbox (GDAL/OGR > Geoprocessing).

I meant the lack of stats for dissolves fields.

#3 Updated by Harrissou Santanna over 4 years ago

And I would add the plugin Dissolvewithstats (still tagged as experimental though it works well)

#4 Updated by Giovanni Manghi over 4 years ago

  • Target version changed from Version 2.8.1 to Version 2.8.2

#5 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback.

Also available in: Atom PDF