Bug report #12370

QGIS Desktop V2.8.1 crashes when I press New, Open or Save button

Added by Frank Koconis about 5 years ago. Updated about 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:20545

Description

Just installed QGIS V2.8.1. When I start the QGIS Desktop and press either the New, Open or Save buttons, it crashes and generates a mini-dump. I have attached two.
I searched for this issue and saw a post suggesting that it might help to disable all plug-ins, so I tried that. Interestingly, after I disabled all plug-ins, the New button seems to be OK (no crash), but it still crashes if I press either the Open or Save button.

qgis-20150313-134656-8104-4212-exported.zip (3.64 MB) Frank Koconis, 2015-03-13 11:20 AM

qgis-20150313-135253-1608-7672-exported.zip (3.63 MB) Frank Koconis, 2015-03-13 11:21 AM

History

#1 Updated by Frank Koconis about 5 years ago

It appears that the two crash dump files that I attached were to large to upload. I will try compressing them...

#2 Updated by Frank Koconis about 5 years ago

Second crash dump file, compressed...

#3 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Open to Feedback
  • Category set to Project Loading/Saving

did you had any previous qgis release installed? if yes try deleting the .qgis2 folder (make a backup first if needed).

#4 Updated by Frank Koconis about 5 years ago

No- this is a new Windows 7 laptop which has never had any version of QGIS on it.

#5 Updated by Giovanni Manghi about 5 years ago

  • Status changed from Feedback to Open

Frank Koconis wrote:

No- this is a new Windows 7 laptop which has never had any version of QGIS on it.

weird, anyway this should be a local issue. Hope someone can have a look to dump files and find a reason for the crash.

#6 Updated by Giovanni Manghi about 3 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Status changed from Open to Closed
  • Priority changed from Normal to High
  • Resolution set to not reproducable

Very likely a local issue, and anyway now obsolete.

Also available in: Atom PDF