Bug report #12301

Identify tool and highlighting behaviour

Added by Mart Reinola about 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Map Canvas
Affected QGIS version:2.8.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20479

Description

In Qgis <2.6 when you clicked on object after object with the info tool, only the last object clicked was highlighted, highlighting on the previous object was turned off (with the auto-open feature attributes form option turned on). In Qgis 2.6 and 2.8, the highlight stays on.

History

#1 Updated by Giovanni Manghi about 5 years ago

  • Category set to Map Canvas
  • Status changed from Open to Feedback

are you sure that you don't have any feature form dialog open? this is usually the source of this "issue".

#2 Updated by Mart Reinola about 5 years ago

I'm sure that i do have the feature dialogs open, and that when i close the dialogs, the highlighting goes off. Yet, in previous versions it didn't matter, only the last object clicked was highlighted.

#3 Updated by Giovanni Manghi about 5 years ago

Mart Reinola wrote:

I'm sure that i do have the feature dialogs open, and that when i close the dialogs, the highlighting goes off. Yet, in previous versions it didn't matter, only the last object clicked was highlighted.

sorry I'm not sure I understand: if you close the identify/form feature dialog, and the highlighting goes away, where is the issue?
The behavior changed from previous qgis releases, but this is known and was by design.

#4 Updated by Mart Reinola about 5 years ago

Before i didnt have to close dialogs, now i do. That means extra clicks. So, in that aspect, the new version is not an improvement.
But, then again, as i understand its by design and ment to work like that, so its not a bug.

#5 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Mart Reinola wrote:

Before i didnt have to close dialogs, now i do. That means extra clicks. So, in that aspect, the new version is not an improvement.
But, then again, as i understand its by design and ment to work like that, so its not a bug.

I see your point, but is really by design.

Also available in: Atom PDF