Feature request #12298

Allow Oracle layers features to be simplified server-side before rendering

Added by Michael Douchin over 2 years ago. Updated 11 months ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/Oracle
Pull Request or Patch supplied:Yes Resolution:wontfix
Easy fix?:No

Description

As for PostGreSQL, it would be nice to let Oracle simplify geometries when featching feature for rendering purpose. This would speed up data retrival.

I have not found any suitable Oracle functions to mimic the 2 methods used for PostGreSQL provider : ST_SnapToGrid and ST_SimplifyPreserveTopology. Perhaps it is not feasible ?

Thanks for any feedback.

QGIS_oracle_pre_rendering_simplification.diff Magnifier (4.45 KB) Michael Douchin, 03/06/2015 09:40 AM

History

#2 Updated by Michael Douchin over 2 years ago

Sure, could be. I am not sure if the PostGis "preservetopology" is needed, since we simplify at a pixel level...

#3 Updated by Michael Douchin over 2 years ago

The tolerance parameter could be used to mimic the "snap to grid" function

#4 Updated by Michael Douchin over 2 years ago

A patch attached with a first code running.

  • I have tested it with only one POLYGON layer, and got awkward results, which seems to be caused by simplification leading to POINT or LINESTRING instead of original geometry type. Perhaps the problems lies also in incorrect geometries in my dataset
  • I kept the tolerance used for PostGIS: mRequest.simplifyMethod().tolerance() * 0.8 There is surely a room for improvement here
  • I do not know if the patch is suitable for both Oracle Locator and Oracle spatial

Please test the attached diff file and give feedback or advice

NB: This is the first time I work with Oracle. I invite Oracle Locator/Spatial gurus to participate, since I am a complete newbie here

NB2: You can use the docker/oracle here to set up a test environment.

#5 Updated by Michael Douchin over 2 years ago

I need to to some benchmarking as described in #8725

#6 Updated by Médéric RIBREUX 11 months ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Hello,

I am closing this one because we have tried but it seems that simplifying from Oracle server just takes much more time than simply retrieving native features.

Oracle database server doesn't seem to be able to simplify features with loading time improvment...

Also available in: Atom PDF