Bug report #12233

Cannot change fonts in print composer

Added by Anita Graser over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Jürgen Fischer
Category:Map Composer/Printing
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20420

Description

Affects both the font picker for legends as well as for label items. (Colors which can be selected separately do work)

Tested using 2.8 and master from OSGeo4W on Win7 and Win8.


Related issues

Duplicates QGIS Application - Bug report #4937: Print composer: font size in label restricted to chosen f... Closed 2012-02-01
Duplicated by QGIS Application - Bug report #12237: Cannot change font in print composer Closed 2015-02-22
Duplicated by QGIS Application - Bug report #12260: Print Composer: Text field is not updated when chaning font Closed 2015-02-24

Associated revisions

Revision 57ba28c3
Added by Jürgen Fischer over 4 years ago

don't set parent of QFontDialog to avoid the stylesheet font (fixes #12233)

Revision fe213784
Added by Jürgen Fischer over 4 years ago

don't set parent of QFontDialog to avoid the stylesheet font (fixes #12233)

Revision ec0ab3f7
Added by Jürgen Fischer over 4 years ago

composer attribute table: fix changing header font (fixes #12233)

Revision fe9161f4
Added by Jürgen Fischer over 4 years ago

composer attribute table: fix changing header font (fixes #12233)

(cherry picked from commit ec0ab3f7ce4c7b009cff9abaf9d9277cb62437de)

History

#1 Updated by Anita Graser over 4 years ago

Maybe this recent change caused it 69c58e9eece

#2 Updated by Jürgen Fischer over 4 years ago

Anita Graser wrote:

Maybe this recent change caused it 69c58e9eece

which reverts 6ba79ca :(

#3 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Closed

#4 Updated by Pedro Venâncio over 4 years ago

  • Assignee set to Jürgen Fischer
  • Status changed from Closed to Reopened

This still occurs with Attribute Table item -> Table Heading Font. With Table Contents Font, everything seems ok.

Tested in 2.8.1 and master.

#5 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Reopened to Closed

Also available in: Atom PDF