Feature request #1223

cannot remove islands from multipolygons

Added by Maciej Sieczka - about 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Digitising
Pull Request or Patch supplied: Resolution:duplicate
Easy fix?:No Copied to github as #:11283

Description

1. Open the attached Shapefile.

2. Toggle editing.

3. Navigate to top-left corner.

4. You can't remove any of the separate polygons cause all have the same id - you can only remove all polygons (i.e. the entire geometry in the Shapefile) or none.

QGIS should let the user modify Shapefile's geometry independent of it's data table linkage.

dissolve.tar.bz2 - Shapefile to reproduce the bug (53.2 KB) Maciej Sieczka -, 2008-08-20 06:17 AM

History

#1 Updated by Jürgen Fischer about 12 years ago

Looks like there's only one feature in you shape and that feature is a multipolygon. The problem is that there currently is no way to delete islands from a multipolygon.

#2 Updated by Jürgen Fischer about 12 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #1042

#3 Updated by Maciej Sieczka - about 12 years ago

Replying to [comment:3 jef]:

duplicate of #1042

Not entirely - #1042 is about islands, this one one is about rings. Enough to re-open this ticket?

#4 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF