Bug report #12218

python error when using postgis inputs in Processing ogr tools

Added by Giovanni Manghi over 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Victor Olaya
Category:Processing/GDAL
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:20406

Description

Uncaught error while executing algorithm
Traceback (most recent call last):
Traceback (most recent call last):
  File "/usr/share/qgis/python/plugins/processing/core/GeoAlgorithm.py", line 232, in execute
    self.processAlgorithm(progress)
  File "/usr/share/qgis/python/plugins/processing/algs/gdal/ogrinfo.py", line 55, in processAlgorithm
    conn = self.ogrConnectionString(layer)
  File "/usr/share/qgis/python/plugins/processing/algs/gdal/OgrAlgorithm.py", line 75, in ogrConnectionString
    QgsCredentials.instance().put(conninfo, user, passwd)
UnboundLocalError: local variable 'user' referenced before assignment

likely caused by f540cd1

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Also available in: Atom PDF