Bug report #1220

transparency for point layers does not work

Added by Steven Mizuno about 11 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Symbology
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11280

Description

The Transparency control on Layer Properties, Symbology for a Point layer does not affect the map display.

on Linux and Windows, as of r9044

Associated revisions

Revision 421d5aa1
Added by Magnus Homann about 10 years ago

Made point symbols respect the layer transparency setting. Fixes #1220

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision ca0b14db
Added by Magnus Homann about 10 years ago

Made point symbols respect the layer transparency setting. Fixes #1220

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 2c666b71
Added by Magnus Homann about 10 years ago

Different approach to backwards compatibility. Fixes #1220 again

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision b4774285
Added by Magnus Homann about 10 years ago

Different approach to backwards compatibility. Fixes #1220 again

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Giovanni Manghi about 10 years ago

This is still true as for QGis 1.2 rev. 11005.

#2 Updated by Magnus Homann about 10 years ago

Added a fix in ca0b14db (SVN r11276).

#3 Updated by Giovanni Manghi about 10 years ago

I don't know if it was this fix, but right now I cannot compile (ca0b14db (SVN r11276))

[ 59%] Generating core/core.so
sipcoreQgsRenderer.cpp: In function ‘void* init_QgsRenderer(sipWrapper*, [[PyObject]]*, sipWrapper**, int*)’:
sipcoreQgsRenderer.cpp:817: error: cannot allocate an object of abstract type ‘sipQgsRenderer’
sipcoreQgsRenderer.cpp:172: note:   because the following virtual functions are pure within ‘sipQgsRenderer’:
/home/gio/Desktop/qgis_unstable/src/core/renderer/qgsrenderer.h:79: note:     virtual void [[QgsRenderer]]::renderFeature(QgsRenderContext&, [[QgsFeature]]&, QImage*, bool, double)
sipcoreQgsRenderer.cpp:829: error: cannot allocate an object of abstract type ‘sipQgsRenderer’
sipcoreQgsRenderer.cpp:172: note:   since type ‘sipQgsRenderer’ has pure virtual functions
maker3: *** [sipcoreQgsRenderer.o] Error 1
maker2: *** [python/core/core.so] Error 2
maker1: *** [python/CMakeFiles/python.dir/all] Error 2
make: *** [all] Error 2

#4 Updated by Magnus Homann about 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Okay, tried a different approach in b4774285 (SVN r11277)

#5 Updated by Giovanni Manghi about 10 years ago

seems I'm getting the same error

[ 59%] Generating core/core.so
sipcoreQgsRenderer.cpp: In function ‘void* init_QgsRenderer(sipWrapper*, [[PyObject]]*, sipWrapper**, int*)’:
sipcoreQgsRenderer.cpp:817: error: cannot allocate an object of abstract type ‘sipQgsRenderer’
sipcoreQgsRenderer.cpp:172: note:   because the following virtual functions are pure within ‘sipQgsRenderer’:
/home/gio/Desktop/qgis_unstable/src/core/renderer/qgsrenderer.h:80: note:     virtual void [[QgsRenderer]]::renderFeature(QgsRenderContext&, [[QgsFeature]]&, QImage*, bool, double)
sipcoreQgsRenderer.cpp:829: error: cannot allocate an object of abstract type ‘sipQgsRenderer’
sipcoreQgsRenderer.cpp:172: note:   since type ‘sipQgsRenderer’ has pure virtual functions
maker3: *** [sipcoreQgsRenderer.o] Error 1
maker2: *** [python/core/core.so] Error 2
maker1: *** [python/CMakeFiles/python.dir/all] Error 2
make: *** [all] Error 2

#6 Updated by Magnus Homann about 10 years ago

Three strikes and out! b4f7e942 (SVN r11278)

#7 Updated by Giovanni Manghi about 10 years ago

foul ball! :)

 59%] Generating core/Makefile, gui/Makefile
Parsing SIP files for 'core' library...
/usr/bin/sip -c core -b /home/gio/Desktop/qgis_unstable/python/core/core.sbf -I /usr/share/sip/PyQt4 -x [[VendorID]] -t WS_X11 -x [[PyQt]]_NoPrintRangeBug -t Qt_4_4_1 -g /home/gio/Desktop/qgis_unstable/python/core/core.sip
sip: /home/gio/Desktop/qgis_unstable/python/core/qgssymbol.sip:81: syntax error
Parsing SIP files for 'gui' library...
/usr/bin/sip -c gui -b /home/gio/Desktop/qgis_unstable/python/gui/gui.sbf -I /home/gio/Desktop/qgis_unstable/python -I /usr/share/sip/PyQt4 -x [[VendorID]] -t WS_X11 -x [[PyQt]]_NoPrintRangeBug -t Qt_4_4_1 -g /home/gio/Desktop/qgis_unstable/python/gui/gui.sip
sip: core/qgssymbol.sip:81: syntax error
Creating makefiles...
Creating qgisconfig.py...
Done
[ 59%] Generating core/core.so
sipcoreQgsRenderer.cpp: In function ‘void* init_QgsRenderer(sipWrapper*, [[PyObject]]*, sipWrapper**, int*)’:
sipcoreQgsRenderer.cpp:817: error: cannot allocate an object of abstract type ‘sipQgsRenderer’
sipcoreQgsRenderer.cpp:172: note:   because the following virtual functions are pure within ‘sipQgsRenderer’:
/home/gio/Desktop/qgis_unstable/src/core/renderer/qgsrenderer.h:80: note:     virtual void [[QgsRenderer]]::renderFeature(QgsRenderContext&, [[QgsFeature]]&, QImage*, bool, double)
sipcoreQgsRenderer.cpp:829: error: cannot allocate an object of abstract type ‘sipQgsRenderer’
sipcoreQgsRenderer.cpp:172: note:   since type ‘sipQgsRenderer’ has pure virtual functions
maker3: *** [sipcoreQgsRenderer.o] Error 1
maker2: *** [python/core/core.so] Error 2
maker1: *** [python/CMakeFiles/python.dir/all] Error 2
make: *** [all] Error 2

#8 Updated by Magnus Homann about 10 years ago

jef did a small adjustment, does it work now?

#9 Updated by Giovanni Manghi about 10 years ago

Replying to [comment:8 homann]:

jef did a small adjustment, does it work now?

perfect! thanks!

Also available in: Atom PDF