Bug report #12193

Problem with update a sql query in DBManager

Added by Pedro Venâncio over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20383

Description

In DB Manager -> SQL Window, if you write a SQL query, run and then change some parameter, making the selection with the mouse, the query does not work/update. On the other hand, if you delete and write the new parameter, then it works. In other words, you must move the cursor with the keyboard.

I made a short screencast because it is not very easy to explain. The first example in the video is with QGIS 2.6.1 and the second with the Master.

https://dl.dropboxusercontent.com/u/5772257/qgis/dbmanager_sql_window.avi

So it is a regression, but nothing serious.

Tested in Windows (OSGeo4W 64bits) and Linux.

Associated revisions

Revision c3d9f10c
Added by Martin Dobias over 4 years ago

Fix #12193 - problem with update of SQL query in DB manager

In the scenario described in the bug report, the selected text was empty,
but editor's hasSelectedText() would still return True

History

#1 Updated by Martin Dobias over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF