Bug report #12172

Use xvfb-run on "make check"

Added by Sandro Santilli over 5 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Tests Suite
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20364

Description

I don't think there's any reason for "make check" to map windows on the running desktop, so why not always running xvfb-run when available ?

Associated revisions

Revision eddf23c3
Added by Sandro Santilli about 3 years ago

Make the `check` rule use xvfb-run, drop `check-no-x`

I see no reason for anyone wanting to see popping windows during
a `make check` run. Closes #12172.

History

#1 Updated by Sandro Santilli over 5 years ago

I just found out there's a "check-no-x" Makefile rule. Why not making that the default for "check" ?
Or what's the reason to test against the real X ?

#2 Updated by Sandro Santilli over 4 years ago

As of current master (2.14-pre) I hadn't seen windows popping up on "make check", but there's still a "check-no-x" rule. Was it obsoleted ?

#3 Updated by Sandro Santilli about 4 years ago

I saw the windows again (maybe last time I just didn't have DISPLAY set). So I think I'll push a change having "make check" run the test w/out X... We need to simplify testing IMHO.

#4 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#5 Updated by Sandro Santilli about 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF