Bug report #12152

Consider point rotation for rotated maps

Added by Andreas Neumann over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:Sandro Santilli
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20345

Description

Rotated symbols that have a data-defined rotation field or are rotated with "Symbology -> advanced -> rotation field" need to be treated similar to manually placed fonts.

An example:

A cadastral map with a symbol indicating the flow-direction of a river. See attached image at angle 0. If I rotate the map, the arrow symbol should still correctly indicate the flow-direction of the river - but with the current behaviour it stays at the original rotation value (see screenshot at 45 degree angle).

There may be some cases where the symbols shouldn't be rotated with the map, but I think in most cases you want the symbol to be rotated as well. Maybe, for a future QGIS version, there needs to be an option whether the symbol should be rotated with the map or not. For now we would just add the map rotation to the symbol rotation as well.

qgis_rotated_symbols_at_angle_0.png - An example symbol at map rotation "0" (44.4 KB) Andreas Neumann, 2015-02-08 03:41 AM

qgis_rotated_symbols_at_angle_45.png - The same symbol at map rotation "45" where the map rotation is not added to the symbol rotation. (70.8 KB) Andreas Neumann, 2015-02-08 03:41 AM

Associated revisions

Revision 5397d6b4
Added by Sandro Santilli over 4 years ago

Add map rotation to symbol rotation

Only affects point marker symbols with data-defined rotation.
Fix #12152

History

#1 Updated by Sandro Santilli over 4 years ago

  • Affected QGIS version changed from 2.6.0 to master
  • Tag set to rotation

#3 Updated by Sandro Santilli over 4 years ago

  • % Done changed from 0 to 20

#4 Updated by Sandro Santilli over 4 years ago

It looks like data-defined rotation does not work for symbols attached to linear features. Can you confirm that ?
Should that be considered a bug of its own ?

#5 Updated by Andreas Neumann over 4 years ago

Do you mean for "marker lines"?

I don't know. I have not tried. I usually use the "auto" rotation of markers at a marker line - which is probably what covers 99% of the use cases. In the "auto rotation" scenario, the markers are rotated perpendicular to the line at segments and according to the bisector angle at vertices (I think).

#6 Updated by Sandro Santilli over 4 years ago

I mean for markers you apply to lines. For example arrows at the first or last point of lines.
There seem to be an additional option in that case, which is "rotate" symbol. With "rotate" the marker is rotated following the line orientation, otherwise it isn't. In any case the Advanced->RotationField seems to do nothing.

#7 Updated by Andreas Neumann over 4 years ago

Ok - got it. It is probably a bug if it isn't working. But then I don't see a use-case why one wants to completely rotate a line.

It is probably a bug that this option is still available for line or polygon geometries.

I thought there was a pull request to remove these advanced options, because they are also available now at the symbol level.

In my opinion, this rotation option only makes sense for point data.

#8 Updated by Sandro Santilli over 4 years ago

If you find that ticket please link it here. It would be useful to do cleanups before 2.8 gets out.

#9 Updated by Sandro Santilli over 4 years ago

  • Status changed from Open to Closed

#10 Updated by Sandro Santilli over 4 years ago

  • % Done changed from 20 to 100

Also available in: Atom PDF