Bug report #1215

"blue pencil" Attribute Edit

Added by Serge Dikiy about 12 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:GUI
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11275

Description

Can not edit object attributes -- when clicking on object in edit mode, info popup appears. Should appear "Enter attribute values", but "Identify results" pops up.

http://forum.qgis.org/viewtopic.php?f=2&t=1349&st=0&sk=t&sd=a&start=15

History

#1 Updated by Serge Dikiy about 12 years ago

Please, modify QgsMapToolIdentify::identifyVectorLayer in /trunk/qgis/src/app/qgsmaptoolidentify.cpp (add line from 417,516 to 589 in really used function). If [email protected] possible.

#2 Updated by Serge Dikiy about 12 years ago

Hi, Marco

What reason for remove ability 'Attribute Edit' in QgsMapToolIdentify::identifyVectorLayer 2002f683 (SVN r7885)?

[https://trac.osgeo.org/qgis/browser/trunk/qgis/src/app/qgsmaptoolidentify.cpp?rev=7884]

Thank you.

#3 Updated by Marco Hugentobler about 12 years ago

Hi sdikiy

The reason is that QgsVectorLayer is not able to cope with geometry edits and attribute edits (uncommited changes) at the same time. It is a deficiency and hopefully it can be solved in the future. Because of this deficiency, the attribute table is modal for attribute edits such that user has to close it before doing further map editing. In the same sense, I commented out the code in QgsMapToolIdentify that would allow users to change values in edit mode.

Marco

#4 Updated by Jürgen Fischer about 12 years ago

Replying to [comment:3 mhugent]:

The reason is that QgsVectorLayer is not able to cope with geometry edits and attribute edits (uncommited changes) at the same time.

What a coincidence. I just ran into that problem and working it...

See http://lists.osgeo.org/pipermail/qgis-developer/2008-August/004602.html

#5 Updated by Jürgen Fischer about 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in 43278d72 (SVN r9093)

#6 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

#7 Updated by Serge Dikiy over 10 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

"Can not edit object attributes -- when clicking on object..." :-(

#8 Updated by Jürgen Fischer over 10 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

Replying to [comment:7 sdikiy]:

"Can not edit object attributes -- when clicking on object..." :-(

Huh? You can set the configure the identify tool to open the feature form when you identify a single feature - which is in editing mode, if the layer is. If you hit multiple features, you need to open a feature form for each feature from the action form.

Also available in: Atom PDF