Bug report #12140

Opening a new project within python plugin causes blank screen

Added by Shashank khare almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:2.6.0 Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:20334

Description

Hi!

I am trying to close the current project and open a new project in my python plugin with help of following code:
QgsProject.instance().clear()
QgsProject.instance().setFileName('d:/shashank/test/second.xml.qgs')
QgsProject.instance().read()

The above throws up a blank screen. The code works fine in python console but it does not work inside my plugin.
Looks like cleanup issues with python binding.

-Shashank

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

this seems more like a question rather than a issue report. Please check with the devs in the developers mailing list or #qgis irc channel, then eventually reopen this ticket.

Also available in: Atom PDF