Bug report #12132

Attribute editing refresh problem

Added by Richard Oates almost 5 years ago. Updated almost 5 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Attribute table
Affected QGIS version:2.6.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20326

Description

Hi,

I have noticed a problem in successive versions of QGIS (and also on version 2.6):
When editing a value of an attribute in an attribute table, the completed edit doesn't always display after the edit. Only when you save the table, do your attribute edits become visible.

The same behaviour is observed when using the field calculator:
After calculating the values of an attribute to be a certain output, the edited values don't look like they have changed until the table is saved.

There appears to be an attribute refresh problem and this is very annoying when you are dealing with a large number of sorted records in a table.

It also damages the credibility of QGIS by creating doubt over its' data handling integrity.

It would be great if this issue could be addressed promptly as it is a long-standing issue.

History

#1 Updated by Giovanni Manghi almost 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #10976

Also available in: Atom PDF