Bug report #12110

dbManager - cannot import name QAbstractTableModel

Added by Pedro Venâncio over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20304

Description

This error occurs whenever I try to run a query in DBManager SQL window, in master version 2.7.0-87 (OSGeo4W 64bit).

An error has occured while executing Python code:

Traceback (most recent call last):
  File "C:/OSGEO4~1/apps/qgis-dev/./python/plugins\\db_manager\\dlg_sql_window.py", line 155, in executeSql
    model = self.db.sqlResultModel( sql, self )
  File "C:/OSGEO4~1/apps/qgis-dev/./python/plugins\\db_manager\\db_plugins\\postgis\\plugin.py", line 116, in sqlResultModel
    from .data_model import PGSqlResultModel
  File "C:/OSGEO4~1/apps/qgis-dev/./python\\qgis\\utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/OSGEO4~1/apps/qgis-dev/./python/plugins\\db_manager\\db_plugins\\postgis\\data_model.py", line 25, in 
    from ..data_model import TableDataModel, SqlResultModel
  File "C:/OSGEO4~1/apps/qgis-dev/./python\\qgis\\utils.py", line 478, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/OSGEO4~1/apps/qgis-dev/./python/plugins\\db_manager\\db_plugins\\data_model.py", line 24, in 
    from PyQt4.QtGui import QAbstractTableModel, QFont, QStandardItemModel, QStandardItem, QApplication
ImportError: cannot import name QAbstractTableModel

Python version:
2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)]

QGIS version:
2.7.0-Master Master, 6e94688

It does not happen in 2.6.1 and did not happen in the master version until last Friday.

History

#1 Updated by Pedro Venâncio over 4 years ago

At this moment it can not be tested in Linux because of #12011

#2 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Closed

fixed in ca459ee4e

Also available in: Atom PDF