Bug report #12105

QGIS-master: undeclared identifier 'lastUsedFilter'

Added by Rainer Hurling over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:master Regression?:No
Operating System:FreeBSD Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:20299

Description

From 1e936df on Jan 26, 2015 and newer, I can't build QGIS master on FreeBSD:

[..snip..]
[ 30%] Building CXX object src/gui/CMakeFiles/qgis_gui.dir/layertree/qgslayertreeviewdefaultactions.cpp.o
[ 30%] Building CXX object src/gui/CMakeFiles/qgis_gui.dir/qgisgui.cpp.o
/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63/src/gui/qgisgui.cpp:148:11: error: use of undeclared identifier 'lastUsedFilter'; did you mean 'lastUsedDir'?
    if ( !lastUsedFilter.isEmpty() )     // set the filter to the last one used
          ^~~~~~~~~~~~~~
          lastUsedDir
/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63/src/gui/qgisgui.cpp:108:13: note: 'lastUsedDir' declared here
    QString lastUsedDir = settings.value( "/UI/lastSaveAsImageDir", "." ).toString();
            ^
/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63/src/gui/qgisgui.cpp:150:37: error: use of undeclared identifier 'lastUsedFilter'; did you mean 'lastUsedDir'?
      fileDialog->selectNameFilter( lastUsedFilter );
                                    ^~~~~~~~~~~~~~
                                    lastUsedDir
/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63/src/gui/qgisgui.cpp:108:13: note: 'lastUsedDir' declared here
    QString lastUsedDir = settings.value( "/UI/lastSaveAsImageDir", "." ).toString();
            ^
2 errors generated.
src/gui/CMakeFiles/qgis_gui.dir/build.make:3549: die Regel für Ziel „src/gui/CMakeFiles/qgis_gui.dir/qgisgui.cpp.o“ scheiterte
gmake[4]: *** [src/gui/CMakeFiles/qgis_gui.dir/qgisgui.cpp.o] Fehler 1
gmake[4]: Verzeichnis „/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63“ wird verlassen
CMakeFiles/Makefile2:1319: die Regel für Ziel „src/gui/CMakeFiles/qgis_gui.dir/all“ scheiterte
gmake[3]: *** [src/gui/CMakeFiles/qgis_gui.dir/all] Fehler 2
gmake[3]: Verzeichnis „/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63“ wird verlassen
Makefile:147: die Regel für Ziel „all“ scheiterte
gmake[2]: *** [all] Fehler 2
gmake[2]: Verzeichnis „/usr/ports/graphics/qgis-devel/work/qgis-QGIS-fe27b63“ wird verlassen
*** Error code 1

A complete log is attached.

- This happens on a box running FreeBSD 11-CURRENT (HEAD) amd64 (r277948)
- The build uses the system compiler FreeBSD clang version 3.5.1 (tags/RELEASE_351/final 225668) 20150115
- However, same result with gcc48 (FreeBSD Ports Collection) 4.8.5 20150122 (prerelease)

As far as I understand, commit 1e936df seems to be not complete?

qgis-master.log Magnifier - Log from broken build process (87.5 KB) Rainer Hurling, 2015-01-31 05:46 AM

patch-src__gui__qgisgui.cpp Magnifier - workaround for missing lastUsedFilter (492 Bytes) Rainer Hurling, 2015-02-17 10:10 AM

Associated revisions

Revision 1c3472ab
Added by Jürgen Fischer over 4 years ago

fix freebsd build (fixes #12105)

History

#1 Updated by Rainer Hurling over 4 years ago

As described above, I have problems in building qgis master on FreeBSD since git hash 1e936df. Reintroducing a one liner (attached patch) from before 1e936df seems to solve the build problem for FreeBSD.

Since other Unix alike systems do not report about such problems, there must be another reason for this failure on FreeBSD. Unfortunately, I have not enough skills to isolate the real cause.

#2 Updated by Jürgen Fischer over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF