Bug report #12103

Error opening SQL Editor in DBManager

Added by Luca Lanteri over 5 years ago. Updated over 5 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System:linux mint Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:20297

Description

On qgis master 2.7 on linux mint when I try to open the sql editor DBManager return this error:

Traceback (most recent call last):
  File "/home/luk/bin/qgis2.8_cr/share/qgis/python/plugins/db_manager/db_manager.py", line 183, in runSqlWindow
    from dlg_sql_window import DlgSqlWindow
  File "/home/luk/bin/qgis2.8_cr/share/qgis/python/qgis/utils.py", line 479, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/luk/bin/qgis2.8_cr/share/qgis/python/plugins/db_manager/dlg_sql_window.py", line 33, in 
    from .ui.ui_DlgSqlWindow import Ui_DbManagerDlgSqlWindow as Ui_Dialog
  File "/home/luk/bin/qgis2.8_cr/share/qgis/python/qgis/utils.py", line 479, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/luk/bin/qgis2.8_cr/share/qgis/python/plugins/db_manager/ui/ui_DlgSqlWindow.py", line 222, in 
    from qgis.gui import QgsCodeEditorSQL
ImportError: cannot import name QgsCodeEditorSQL

History

#1 Updated by Giovanni Manghi over 5 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #12011

Also available in: Atom PDF