Bug report #1210

Postgis: columns with enum datatypes are not shown in attribute table

Added by Andreas Neumann about 13 years ago. Updated about 12 years ago.

Status:Closed
Priority:Low
Assignee:Jürgen Fischer
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11270

Description

Attribute tables with Postgis sources don't show columns with data type "enum". Enums are available in PostgreSQL 8.3 or later.

Ideally, the attribute table would show a choice of all available enum values as a drop-down list, but in the meanwhile it would be good enough if they would be shown as plain text.

Thank you for having a look at this bug.

Associated revisions

Revision 9dbe4f57
Added by Jürgen Fischer about 13 years ago

postgres provider update
- track open cursors and commit transaction whenever no open cursors are left
- close cursor after immediately after feature retrieval (releases locks earlier)
- wrap postgres calls in Conn class
- introduce Result class to handle PQclear mostly transparently (fixes minor leaks)
- remove executeDbCommand method (duplicate of PQexecNR)
- introduce support for estimate_extents (fixes #582)
- introduce support for enum types (fixes #1210)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision b9452c2d
Added by Jürgen Fischer about 13 years ago

postgres provider update
- track open cursors and commit transaction whenever no open cursors are left
- close cursor after immediately after feature retrieval (releases locks earlier)
- wrap postgres calls in Conn class
- introduce Result class to handle PQclear mostly transparently (fixes minor leaks)
- remove executeDbCommand method (duplicate of PQexecNR)
- introduce support for estimate_extents (fixes #582)
- introduce support for enum types (fixes #1210)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer about 13 years ago

  • Status changed from Open to In Progress

#2 Updated by Jürgen Fischer about 13 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

added in b9452c2d (SVN r9184)

#3 Updated by Anonymous about 12 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF